[Corpora-List] Stupid tgrep problem: negation not working

Kevin B. Cohen kevin.cohen at gmail.com
Thu Nov 13 17:47:24 CET 2008


List members,

I am having a dumb tgrep problem that I'm hoping someone else might have run into. I'm trying to specify 'does not (immediately) dominate.' However, I keep getting messages saying "Event not found" with respect to the dominance or immediate dominance operator.

If I don't negate the dominance/immediate dominance operator, everything is fine. Thus:

babel>tgrep 'ADJP < CC' | more

(ADJP (VBG increasing)

(CC and)

(VBG diversifying))

(ADJP (RB so)

(JJ fragile)

(CC and)

(JJ minute))

But:

babel>tgrep 'ADJP !< CC' | more <: Event not found

I've tried this with single quotes and double quotes--no difference. I've also tried it with the precedence operator--same pattern.

Any hints?

Kev -- K. B. Cohen Biomedical Text Mining Group Lead, Center for Computational Pharmacology and Lead Artificial Intelligence Engineer, The MITRE Corporation, Human Language Technology Division 303-916-2417 (cell) 303-377-9194 (home) http://compbio.uchsc.edu/Hunter_lab/Cohen



More information about the Corpora mailing list